版本变更

1.5.2 (2021/07/09)

  • 增加程序依赖库检测, 若用户 Windows 环境下缺少VC++运行库, 提示用户进行安装.

  • 修复交易单元获取不存在的持仓异常崩溃的问题.

1.5.1 (2021/07/06)

  • 完善用户登录信息提示, 登录失败时, 给出详细失败原因.

  • 完善下单和调仓下单信息提示, 下单失败时, 给出详细失败原因.

  • 修复调仓模块先执行 wait_update() 后执行 set_target_volume() 导致的错误平仓的问题.

1.4.14 (2021/07/02)

  • 修复 linux 环境下实盘账户登录失败的问题.

1.4.13 (2021/06/25)

  • 做市时间段参数格式调整, 调整后格式形如 [('091000', '101000'),('210000', '250000')].

1.4.12 (2021/06/21)

  • 做市模块参数默认值调整: 净持仓限制默认值调整为 100 手; 平仓亏损额默认值调整为 10000 元.

1.4.10 (2021/06/18)

  • 持仓、委托和成交支持 keys() items() values() 等方法进行遍历.

1.4.9 (2021/06/17)

  • 行情时间精度与 tqsdk 保持一致, 纳秒统一保留 6 位.

  • tqsdk2 支持做市模块,参考文档:TqSdk2 做市模块

1.4.8 (2021/06/16)

  • 修复账户实例中, 可用资金字段(available)缺失的问题.

  • 修复持仓实例中, 昨空仓(pos_short_his)和今空仓(pos_short_today)字段错误的问题.

1.4.7 (2021/06/10)

  • 完善回测订阅 tick 和 Kline 数据时合约代码格式校验提示信息

  • 修复 web gui 启动时, 端口冲突异常退出的问题: web gui 端口格式错误或被占用, tqsdk2 会报错退出.

1.4.6 (2021/06/09)

  • 修复订阅多合约 tick 数据为空的问题

1.4.5 (2021/06/09)

  • 修复成交遍历错误的问题

  • 支持交易单元

1.4.2 (2021/06/03)

  • 修复主连合约回测时可能提前结束的问题

1.4.1 (2021/06/02)

  • TqApi 中提供参数 disable_print,可以禁止 TqApi 在屏幕输出内容

  • 修复成交对象遍历崩溃的问题

  • 修复 TqSim 初始化资金不生效的问题

  • 用户认证支持字符串格式(auth="username,password")

1.4.0 (2021/05/27)

  • web_gui 支持手续费统计和历史资金权益变动曲线图

  • web_gui 支持指定端口

  • 优化下单逻辑, 提升下单速度

1.3.8 (2021/05/25)

  • OTG 中继登录支持自动确认结算单

1.3.7 (2021/05/24)

  • 修复主连和指数行情获取失败的问题

  • 账户、持仓、委托和成交对象 get 方法声明为私有

1.3.6 (2021/05/21)

  • 修复 linux 环境下程序崩溃的问题

  • 优化下单逻辑, 提升下单速度

1.3.5 (2021/05/20)

  • 修复 web_gui 获取回测报告失败的问题

1.3.3 (2021/05/19)

  • 修复主连和指数行情获取失败的问题

1.3.2 (2021/05/16)

  • web_gui 支持URL地址指定

1.3.1 (2021/05/13)

  • 支持 python 3.6.4 及以上版本

  • 修复 is_changing 判断 kline 对象错误的问题

1.3.0 (2021/05/13)

  • 回测支持统计报告

  • 委托/成交/持仓对象支持遍历

  • 默认登录自动确认结算单

1.2.9 (2021/05/10)

  • 修复获取主连合约为空导致程序异常退出的问题

1.2.8 (2021/04/29)

  • 支持主连获取当前主力合约

  • wait_update 支持超时不阻塞

1.2.7 (2021/04/29)

  • 修复 Linux 发布包运行错误的问题

  • 修复获取行情实例缺少合约乘数的问题

1.2.6 (2021/04/27)

  • 支持 web_gui

  • 支持融航资管接口

1.2.5 (2021/04/21)

  • 修复 Linux 环境下发布包安装需要手工设置环境变量的问题

Linux 环境下, 需要 G++ 9.3.0 版本及以上。推荐使用 Ubuntu 20.04.

1.2.4 (2021/04/20)

  • 修复 Linux 环境下发布包安装失败的问题

1.2.2 (2021/04/14)

  • 修复回测时, 获取 k线 节假日推进失败的问题

  • 修复回测时, 获取 tick 数据因盘前数据异常导致的推进失败的问题

1.2.1 (2021/04/13)

  • 增加回测成交信息通知

1.2.0 (2021/04/13)

  • ischanging 函数支持批量委托和持仓

  • 修复回测主连获取失败的问题

1.1.9 (2021/04/13)

  • 修复 python 3.7 版本启动时加载动态库失败的问题

1.1.8 (2021/04/09)

  • 修复 OTG 登录失败的问题